Applies to
- Carousel 7.0+
Symptoms
- When checking statuses of the Carousel, Carousel Rendering Service, and RabbitMQ services, you receive a WMI Access Denied response.
- Carousel\IIS AppPool is running under a domain account.
Cause
In Windows, by default, only local administrators can have access to WMI remotely.
Resolution
- Add user to Performance Log Users local group:
- Open the Local Users and Groups Management Console via lusrmgr.msc.
- Select Groups.
- Right-click on Performance Log Users, and select Add to Group...
- Click Add...
- Select the domain account you are using for the Carousell\IIS AppPool.
- Click OK as you close all windows.
- Allow user access to WMI:
- Open WMI Mangement Console via wmimgmt.msc.
- Right-click WMI Control and select Properties.
- Go to the Security tab.
- Expand Root, and highlight CIMV2.
- Click Security.
- Click Add...
- Select the domain account you are using for the Carousel\IIS AppPool.
- Click OK as you close all windows.
- Reboot System
You should now receive information about services via the Carousel System Health check page.
Outline of steps for resolution taken from http://www.gsx.com/blog/bid/86455/Enable-Remote-WMI-Access-for-a-Domain-User-Account post.